That link is still correct, however, you now need to register in order to download the installer AFAIK.

svn: E155021: This client is too old to work with the working copy at '/Users/dpowell/Desktop/sites/new' (format 31). For more details, see The Python script you downloaded from there was to downgrade your SVN version - you need to upgrade your SVN version.

- handles 'file' scheme This is not the most recent version of subversion. Therefore I want to upgrade the commandline subversion client.

updating subversion mac-76

- with Cyrus SASL authentication - handles 'svn' scheme * ra_local : Module for accessing a repository on local disk.

- handles 'file' scheme * ra_serf : Module for accessing a repository via Web DAV protocol using serf.

If you need pre-compiled binaries, please see 'Related Links' below.

Updated and based off Note: To compile and install SVN 1.8 you need Xcode with the Command Line Tools installed.

I recommend going the homebrew route - it will save you lots of pain in upgrading / installing OSX packages in the future.

After some confusion, I realized Subclipse checked out the repository using SVN version 1.7.NOTE: If /opt/subversion/bin already exists, it will be backed up to /opt/subversion_backup. Another option is to go here: which does NOT require registration.Although I expanded on it, I encourage you to read the original post.For completeness, I outlined the full process below. neon allows you to connect to remote SVN repositories via HTTP and HTTPS. Subversion is a Source Code Management (SCM) application designed to replace CVS - it is similar to CVS in many respects, but adds many new features.