IE7 was superseded by Internet Explorer 8 in March 2009.In 2001, Microsoft released Internet Explorer 6 as an update to Windows 98 Second Edition, Windows ME, Windows NT 4.0 with Service Packs 6, and Windows 2000 and included it by default in Windows XP. In late 2007 Microsoft announced that IE7 would not be included as part of Windows XP SP3, with both Internet Explorer 6 and 7 receiving updates.Consequently, you'll likely need to include a download link.

New features include tabbed browsing, page zooming, an integrated search box, a feed reader, better internationalization, and improved support for web standards, although it does not pass the Acid2 or Acid3 tests.

Security enhancements include a phishing filter, stronger encryption on Windows Vista (256-bit from 128-bit in XP), and a "Delete browsing history" button to easily clear private data.

This wiki How will show you how to update the most recent versions of Microsoft Internet Explorer.

It is the default browser in Windows Vista and Windows Server 2008 and can replace Internet Explorer 6 on Windows XP and Windows Server 2003 but unlike version 6, this version does not support Windows NT 4.0, Windows 98, Windows 98 SE, Windows 2000, and Windows ME.

However being on OS X I'm having a hard time managing to find out if Windows Update will actually update IE (from say, 7 to 8) on Windows XP? As a side note, Microsoft won't (by default anyway) even let my OS access any areas of their website where I might find a download link to Internet Explorer 8 or any other version since I'm not on Windows.

Just sayin', if I wanted to supply a link to our users, that is.

Please find below steps to change the settings Control Panel\All Control Panel Items\Windows Update\Change settings Under Important updates option you will find Check for updates but let me choose whether to download and install them. In this case the user will still have to select and accept it, but windows update will do the rest.

I would advise your users to check Windows Update for the latest browser version.

Now I can enter the log in phase but then firefox tell me to install some 2 missing plugins.